目录

ThasBlog

学无止境

Deepin 处理软件包 dde-api (--configure)时出错

root@xcc-deepin:/var/lib# dpkg --configure dde-api 
正在设置 dde-api (5.4.9-1) ...
mkdir: 无法创建目录 “/var/lib/deepin-sound-player”: 权限不够
dpkg: 处理软件包 dde-api (--configure)时出错:
 已安装 dde-api 软件包 post-installation 脚本 子进程返回错误状态 1
在处理时有错误发生:
 dde-api

检查 post-installation 脚本

vi /var/lib/dpkg/info/dde-api.postinst 添加-x调试

image.png

重新执行 dpkg --configure dde-api 发现问题

image.png

以 deepin-sound-player 的身份创建目录,而 /var/lib 权限是 755,所有权限不够, 修改为 777, 保证 /var/lib 对其他用户可写

image.png

done


标题:Deepin 处理软件包 dde-api (--configure)时出错
作者:thas
地址:https://thas.cc/articles/2021/06/30/1625059364605.html